Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#438 closed defect (wontfix)

Startup failure on Emacs 23

Reported by: Makarius Owned by: David Aspinall
Priority: major Milestone: PG-Emacs-4.2
Component: 2:pg-emacs Keywords:
Cc:

Description

PG fails to start up on Emacs 23 (Ubuntu 10.04 LTS), due to called-interactively-p which does not take any arguments.

This is probably caused by the following change:

  Patch from Tom Prince to fix Emacs 24 byte compilation (replace
  interactive-p with called-interactively-p)

Change History (4)

comment:1 in reply to:  description Changed 9 years ago by coquser

PG fails to start up on Emacs 23 (Ubuntu 10.04 LTS), due to called-interactively-p which does not take any arguments.

With emacs 23.3.1 I see

called-interactively-p is a built-in function in `C source code'.

(called-interactively-p KIND)

Return t if the containing function was called by `call-interactively'.
If KIND is `interactive', then only return t if the call was made
interactively by the user, i.e. not in `noninteractive' mode nor
when `executing-kbd-macro'. ...

Hendrik

comment:2 Changed 9 years ago by David Aspinall

Resolution: wontfix
Status: newclosed

Yes, unfortunately it looks like the Emacs developers messed us around by changing this function: first it took no argument (23.1), then a mandatory argument added (from Hendrik's post, 23.3) and now (in 23.4.1 at least), the argument has become optional, I suppose to repair compatibility.

Easiest way to address this is to declare incompatibility for 2009's 23.1 version (unfortunately). I don't want to start adding Emacs version kludges to the code again after a big effort to remove them in last major release.

comment:3 Changed 9 years ago by David Aspinall

PS the download page has always stated that Emacs 23.2 was required for the 4.1 release

comment:4 Changed 6 years ago by courtieu

For the record, it is possible to workaround this bug with old versions of emacs by adding this to config:

(defun called-interactive-p (&optional kind) (interactive-p))

P.

Note: See TracTickets for help on using tickets.