Opened 9 years ago

Closed 8 years ago

#433 closed enhancement (duplicate)

unexpected cursor position after stepping through command with terminator at line ending

Reported by: coquser Owned by: David Aspinall
Priority: minor Milestone: PG-Emacs-4.2
Component: 2:pg-emacs Keywords: usability, cursor position, interactive, terminator at end of line
Cc:

Description

Disclaimer: I am fairly new with PG and not yet used to the terminology, so feel free to correct me when I use the wrong terms.

My setup:
Ubuntu 11.10 (64bit)
GNU Emacs 23.3.1
Coq 8.3pl1 compiled with OCaml 3.11.2

Issue: When I am stepping interactively through a coq script with either the next-command instruction or with the activated electric terminator and the terminator (i.e. the dot) happens to be the last character of that line in the script file, the editor cursor jumps to the beginning of the following line. However, what I would expect is that the cursor either remains where it is or at least that it is positioned after the terminator but on the same line.

This doesn't make a huge difference when stepping through an existing script but when one is developing a new script this behaviour can become really irritating, e.g. with the electric terminator I'd practically be forced to either write each command on a new line or constantly press the back key to reposition the cursor to where I want it.

In case that the former behaviour is intentional, a switch to change the behaviour might be useful (feel free to point me in the right direction if something like this already exists, I couldn't find it so far). Otherwise adjusting this could be considered usability enhancement.

Change History (3)

comment:1 Changed 9 years ago by coquser

Priority: majorminor

comment:2 Changed 9 years ago by coquser

probably duplicate of #377

comment:3 Changed 8 years ago by David Aspinall

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.