Opened 9 years ago

Closed 9 years ago

#394 closed defect (fixed)

Coq "Library" keyword - incorrect coloring

Reported by: coqletsgo Owned by: courtieu
Priority: trivial Milestone: PG-Emacs-4.1
Component: 2:pg-emacs Keywords:
Cc:

Description

When using "Extraction Library <Module>", the "Library" word is not highlighted in blue like all other keywords (Extraction, Require, etc).

Change History (2)

comment:1 Changed 9 years ago by David Aspinall

Owner: changed from David Aspinall to courtieu
Status: newassigned

Confirmed. Yet the patterns are in coq-syntax.el. This seems to happen when the STATECH entry in the table is set to nil.

comment:2 Changed 9 years ago by courtieu

Resolution: fixed
Status: assignedclosed

Hello.

This is fixed in trunk. However the reason of this bug is unclear to me. The workaround was to change the order in which keywords are declared. This needs some more investigation.

P.

Note: See TracTickets for help on using tickets.