Opened 10 years ago

Closed 10 years ago

#389 closed defect (wontfix)

Mac OS X font selection problems

Reported by: Makarius Owned by: David Aspinall
Priority: major Milestone: PG-Emacs-4.1
Component: 2:pg-emacs Keywords:
Cc: makarius@…

Description

This is Mac OS X Snow Leopard, GNU Emacs 23.2.x "non-nonsense". The IsabelleText and IsabelleTextBold Truetype fonts from Isabelle/lib/fonts/ are installed on the system.

Startung Emacs with -fn IsabelleText makes regular text use this really well-rendered font, but the special symbols are taken from other fonts, often coming out as empty boxes instead.

Using the menu Tokens -- Set Font -- Symbol etc. does not make a difference. The font dialog shows "IsabelleText?" but this is not observed. Changing it back and forth a bit does not help either.

Here is a snippet from .emacs resulting from the saved options:

(custom-set-faces
 '(unicode-tokens-symbol-font-face ((t (:slant normal :weight normal :height 120 :width normal :foundry "apple" :family "IsabelleText")))))

Restarting PG / Emacs with the obove does not work either.

Change History (5)

comment:1 Changed 10 years ago by Makarius

The workaround for Isabelle2011 is to enforce STIXGeneral onto the user, and thus benefit from PG's inclinination to use that for symbols.

comment:2 Changed 10 years ago by David Aspinall

Of course, it is an advantage to be able to use different fonts at the same time and this is what happens in LaTeX, etc. Emacs does not need to have a unified font in its display engine unlike poorer display engines elsewhere which cannot mix fonts.

I don't understand why Isabelle text is not selectable, but it might be due to some odd categorization of its weight, slant or whatever.

Does it work on Linux?

comment:3 Changed 10 years ago by Makarius

Yes: Ubuntu LTS 10.04, GNU Emacs 23.1.1.

To me it looks like one of these fancy Mac OS problems, even with the "no-nonsense" Emacs.

comment:4 Changed 10 years ago by Makarius

Without having the Mac OS box available right now, I would say the problem is independent on the actual font being chosen.

comment:5 Changed 10 years ago by David Aspinall

Resolution: wontfix
Status: newclosed

You're right that Mac OS X is doing something odd combine fonts, as changing fonts in the dialog in different orders can result in strange font mixtures; by a sequence of changes I can get a symbol font that is almost completely empty. This combination also happens on Linux, but in different ways.

Note that (see doc of unicode-tokens-symbol-font-face) only the family and slant attributes of the font are copied when a font is chosen. That's deliberate, so font size, for example is taken from the default font to match the text. But it might mean that the symbol font has the wrong combination of attributes to be chosen.

I'm closing this for now as there's no obvious improvement. I've already spent a lot of time when I originally wrote this support messing with things on Mac to get things as far as they are.

Note: See TracTickets for help on using tickets.