Opened 12 years ago

Closed 12 years ago

#178 closed defect (worksforme)

Emacs occasionally hangs when doing isearch-forward.

Reported by: Makarius Owned by: David Aspinall
Priority: major Milestone: PG-Emacs-3.7
Component: 2:pg-emacs Keywords:
Cc:

Description

Using GNU emacs 22.1.1 on Ubuntu 7.10, the editor occasionally hangs when doing isearch-forward.

E.g. reproduce this by visiting Isabelle/src/HOL/Lambda/WeakNorm.thy: type C-s, type "c" "o" "n" "s" (which finds an occurreny of "Cons" in the text), continuing to type "t" makes emacs hang; after C-g it works again, but there is some danger it will again hang later.

Change History (2)

comment:1 Changed 12 years ago by David Aspinall

Can't reproduce with 22.1.1 on Fedora 8, just get immediate search failure.

Presumably this is with X-Symbol enabled, is it reproducible with it off?

Doing

(setq debug-on-quit t)

or

  Options -> Enter Debugger On Quit

May give a useful backtrace with C-g.

comment:2 Changed 12 years ago by David Aspinall

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.